# Maintainer: Dan Johansen <strit@manjaro.org>
# Contributor: Ladislav Nesnera

pkgname=osmin
pkgver=1.9.6
pkgrel=1
_commit=1bf69116ef5e5c68c367351409211b6c775b2375 # tag: 1.9.6
pkgdesc="Satellite Navigator & Tracker On-Road/Off-Road for Mobile"
arch=('aarch64')
url="https://github.com/janbar/osmin"
license=('GPL-3.0')
depends=('openmp' 'qt5-graphicaleffects' 'qt5-location' 'qt5-multimedia' 'qt5-quickcontrols2' 'qt5-sensors' 'qt5-svg' 'qt5-wayland' 'qt5-remoteobjects')
makedepends=('clang' 'cmake' 'double-conversion' 'git' 'glib2' 'md4c' 'tslib' 'xcb-util-image' 'xcb-util-keysyms' 'xdg-utils')
source=( "git+https://github.com/janbar/osmin.git#commit=$_commit")
sha256sums=('SKIP')

prepare() {
  cd "$pkgname"
  git submodule init
  git submodule update
  mkdir -p build
}

build() {
  cd "$pkgname"

  cmake -B build -DBUILD_DEVICE_MOBILE=ON -DCMAKE_C_COMPILER=/usr/bin/clang -DCMAKE_CXX_COMPILER=/usr/bin/clang++ . 
  cmake --build build/
}

package() {
  cd "$pkgname/build"
  make DESTDIR="$pkgdir/" install
}