Commit 1daf2073 authored by Philip Müller's avatar Philip Müller

[pkg-upd] 0.9.0-11

- go back to the known working version
parent 7ec6f79d
......@@ -12,24 +12,21 @@
pkgbase=octopi
pkgname=('octopi' 'octopi-notifier-qt5' 'octopi-notifier-frameworks') #'octopi-repoeditor' 'octopi-cachecleaner'
pkgver=0.9.0
pkgrel=10
pkgrel=11
# This is the release package so the below _gitcommit variable should (usually) be commented out.
#_gitcommit=f94ee1a04b0ca623fb0cae921b5f880692f78608
_gitcommit=d23565750a3a9be20dff5236c9268c2b7d290a13
_gitcommit=359584ba93ebe95df63cbc6d680f74b9e20345c6
arch=('i686' 'x86_64')
url="http://octopiproject.wordpress.com"
license=('GPL2')
makedepends=('qt5-declarative' 'knotifications' 'libnotify' 'alpm-octopi-utils' 'clang' 'qtermwidget' 'qt5-tools')
makedepends=('qt5-declarative' 'knotifications' 'libnotify' 'alpm-octopi-utils' 'clang' 'qtermwidget')
if [ "${_gitcommit}" != "" ]; then
source=("octopi-${pkgver}-${pkgrel}.tar.gz::https://github.com/aarnt/octopi/archive/${_gitcommit}.tar.gz")
else
source=("octopi-${pkgver}.tar.gz::https://github.com/aarnt/octopi/archive/v${pkgver}.tar.gz")
fi
#source+=('remove-qdialog.patch')
sha256sums=('ed64f799eb8a757d2464e76a3d24cd6882e26e1515c2aa05def0a3504c395371')
# 'af8ebc8892a37c866556df391a078a50c6c56a4425e7ef31d35b27871e490229')
sha256sums=('acb94b8a5d99e62717dff7af314430355a01602719337090393ddfc7502e4c17')
prepare() {
if [ ! -z ${_gitcommit} ]; then
......@@ -39,17 +36,14 @@ prepare() {
fi
# sed version
sed -i -e "s|0.10.0 (dev)|${pkgver}-${pkgrel} (git-${_gitcommit:0:6})|g" src/strconstants.cpp
# fix network detection
# patch -p1 -i $srcdir/remove-qdialog.patch
sed -i -e "s|0.9.1 (dev)|${pkgver}-${pkgrel} (git-${_gitcommit:0:6})|g" src/strconstants.cpp
# fix gksu-polkit
# sed -i '/u root -m/d' src/wmhelper.cpp
sed -i '/u root -m/d' src/wmhelper.cpp
cp -r notifier notifier-qt5
cp -r notifier notifier-frameworks
sed -i 's|#KSTATUS|KSTATUS|' notifier-frameworks/octopi-notifier.pro
sed -i 's|#KSTATUS|KSTATUS|' notifier-frameworks/octopi-notifier/octopi-notifier.pro
cp resources/images/octopi_green.png resources/images/octopi.png
}
......@@ -68,21 +62,21 @@ build() {
qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi.pro -spec linux-clang
make -j $jc
cd helper
qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi-helper.pro -spec linux-clang
cd notifier/pacmanhelper
qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" pacmanhelper.pro -spec linux-clang
make -j $jc
cd ../notifier
cd ../../notifier-qt5/octopi-notifier
msg "Building octopi-notifier-qt5..."
qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi-notifier.pro -spec linux-clang
make -j $jc
cd ../notifier-frameworks
cd ../../notifier-frameworks/octopi-notifier
msg "Building octopi-notifier-frameworks..."
qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi-notifier.pro -spec linux-clang
make -j $jc
cd ../repoeditor
cd ../../repoeditor
msg "Building octopi-repoeditor..."
qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi-repoeditor.pro -spec linux-clang
make -j $jc
......@@ -91,16 +85,16 @@ build() {
msg "Building octopi-cachecleaner..."
qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi-cachecleaner.pro -spec linux-clang
make -j $jc
cd ../sudo
qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi-sudo.pro -spec linux-clang
make -j $jc
}
package_octopi() {
pkgdesc="A powerful Pacman frontend using Qt5 libs"
depends=('qt5-base' 'qt5-declarative' 'pacman' 'alpm-octopi-utils>=1.0.0-2' 'qtermwidget' 'sudo')
optdepends=('gist: for SysInfo report'
depends=('qt5-base' 'qt5-declarative' 'xterm' 'pacman' 'alpm-octopi-utils>=1.0.0-2' 'qtermwidget')
optdepends=('kdesu: for KDE'
'gksu-polkit: for XFCE, Gnome, LXDE, Cinnamon'
'lxqt-sudo: for LXQT'
'gnome-keyring: for password management'
'gist: for SysInfo report'
'pacaur: for AUR support'
'trizen: for AUR support'
#'yay: for AUR support'
......@@ -120,17 +114,14 @@ package_octopi() {
make INSTALL_ROOT="${pkgdir}" install
cd helper
cd notifier/pacmanhelper
make INSTALL_ROOT="${pkgdir}" install
cd ../repoeditor
cd ../../repoeditor
make INSTALL_ROOT="${pkgdir}" install
cd ../cachecleaner
make INSTALL_ROOT="${pkgdir}" install
cd ../sudo
make INSTALL_ROOT="${pkgdir}" install
}
package_octopi-repoeditor() {
......@@ -168,9 +159,9 @@ package_octopi-notifier-qt5() {
replaces=('octopi-qt5-notifier' 'octopi-notifier-qt4')
if [ ! -z ${_gitcommit} ]; then
cd "${srcdir}/${pkgbase}-${_gitcommit}/notifier"
cd "${srcdir}/${pkgbase}-${_gitcommit}/notifier-qt5/octopi-notifier"
else
cd "${srcdir}/${pkgbase}-${pkgver}/notifier"
cd "${srcdir}/${pkgbase}-${pkgver}/notifier-qt5/octopi-notifier"
fi
make INSTALL_ROOT="${pkgdir}" install
......@@ -183,10 +174,11 @@ package_octopi-notifier-frameworks() {
provides=("octopi-notifier=${pkgver}")
if [ ! -z ${_gitcommit} ]; then
cd "${srcdir}/${pkgbase}-${_gitcommit}/notifier-frameworks"
cd "${srcdir}/${pkgbase}-${_gitcommit}/notifier-frameworks/octopi-notifier"
else
cd "${srcdir}/${pkgbase}-${pkgver}/notifier-frameworks"
cd "${srcdir}/${pkgbase}-${pkgver}/notifier-frameworks/octopi-notifier"
fi
make INSTALL_ROOT="${pkgdir}" install
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment