diff --git a/PKGBUILD b/PKGBUILD
index 9112a65be836acb2f5c9d24b6039b86e489dd286..55e88a742a4a5a664719d45eb872e0e4948f84ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -270,6 +270,7 @@ package_linux56() {
   depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=27')
   optdepends=('crda: to set the correct wireless channels of your country')
   provides=("linux=${pkgver}" VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
+  install=linux56.install
 
   cd "${srcdir}/linux-${_basekernel}"
 
diff --git a/linux56.install b/linux56.install
new file mode 100644
index 0000000000000000000000000000000000000000..a39c5e9a4c04d6245ae3fc4f46a2c743b248f8f9
--- /dev/null
+++ b/linux56.install
@@ -0,0 +1,16 @@
+eol() {
+  echo ">>> NOTE, 5.6.19 was the last maintenance release by Greg Kroah-Hartman."
+  echo "    This kernel series is now marked EOL (end of life)."
+  echo "    "
+  echo "    It is recommend to move on to linux57 series."
+  echo "    Use followed cmd to do that: 'sudo mhwd-kernel -i linux57'"
+  echo "    "
+}
+
+post_upgrade() {
+  eol
+}
+
+post_install() {
+  eol
+}