diff --git a/0001-renoir-backlight.patch b/0001-revert-96cb7cf.patch
similarity index 94%
rename from 0001-renoir-backlight.patch
rename to 0001-revert-96cb7cf.patch
index ad3280fbd91a2ae253af74321872a9aac1d3948e..65dbcdfbafb826feac67b239e2bf01bd3b82bd97 100644
--- a/0001-renoir-backlight.patch
+++ b/0001-revert-96cb7cf.patch
@@ -5,7 +5,7 @@ index d53c60b37cc6f..f42e7e67ddba4 100644
 @@ -1356,7 +1356,7 @@ static int dm_late_init(void *handle)
  	unsigned int linear_lut[16];
  	int i;
- 	struct dmcu *dmcu = NULL;
+ 	struct dmcu *dmcu = adev->dm.dc->res_pool->dmcu;
 -	bool ret = false;
 +	bool ret;
  
diff --git a/PKGBUILD b/PKGBUILD
index 242c19d3f676ea8ffb8f4582ee563346ffc43595..42678168a24a2f6743776c3fc90bc7932303277a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,7 +38,7 @@ source=("https://www.kernel.org/pub/linux/kernel/v5.x/linux-${_basekernel}.tar.x
         '0001-nonupstream-navi10-vfio-reset.patch'
         '0001-i2c-nuvoton-nc677x-hwmon-driver.patch'
         '0001-iomap-iomap_bmap-should-accept-unwritten-maps.patch'
-        '0001-renoir-backlight.patch'
+        '0001-revert-96cb7cf.patch'
         '0001-apparmor-patch-to-provide-compatibility-with-v2-net-rules.patch'
         '0002-apparmor-af_unix-mediation.patch'
         '0003-apparmor-fix-use-after-free-in-sk_peer_label.patch'
@@ -87,7 +87,7 @@ sha256sums=('de8163bb62f822d84f7a3983574ec460060bf013a78ff79cd7c979ff1ec1d7e0'
             'f1eec160ce5df5c2ea58d4e4fd44a6b1013863c6b3bf649414cd18c89ae500fa'
             '0556859a8168c8f7da9af8e2059d33216d9e5378d2cac70ca54c5ff843fa5add'
             '95745075edd597caa92b369cfbcd11a04c9e3c88c0c987c70114924e1e01df5c'
-            'f8608d46f02ff6c9e7b83e6c8aa2c488c388ee1cf8bc57d69c542f69473f679b'
+            '6e1101a74437ff016ede4768ce104f11cd8b0c609dc290164c5b23f9a9ae0186'
             '98202b8ad70d02d86603294bae967874fa7b18704b5c7b867568b0fd33a08921'
             '5cbbf3db9ea3205e9b89fe3049bea6dd626181db0cb0dc461e4cf5a400c68dd6'
             'c7dbec875d0c1d6782c037a1dcefff2e5bdb5fc9dffac1beea07dd8c1bdef1d7'
@@ -189,8 +189,9 @@ prepare() {
   msg "handling of multiple fans on Lenovo P50"
   patch -Np1 -i "${srcdir}/0001-iomap-iomap_bmap-should-accept-unwritten-maps.patch"
 
-  msg "renoir-backlight patch"
-  patch -Np1 -i "${srcdir}/0001-renoir-backlight.patch"
+  # https://github.com/torvalds/linux/commit/14ed1c9
+  msg "revert-96cb7cf patch"
+  patch -Np1 -i "${srcdir}/0001-revert-96cb7cf.patch"
 
   # Add bootsplash - http://lkml.iu.edu/hypermail/linux/kernel/1710.3/01542.html
   msg "Add bootsplash"