Commit 0666c609 authored by Philip Müller's avatar Philip Müller

[upd-pkg] 20200324-4

parent 6c398bb3
......@@ -3,7 +3,7 @@
pkgname=manjaro-system
pkgver=20200324
pkgrel=3
pkgrel=4
pkgdesc="Manjaro Linux System - Update script"
arch=('any')
url="http://www.manjaro.org"
......
......@@ -44,7 +44,7 @@ post_upgrade() {
# Fix hplip 3.20.3-2 upgrade
if [[ "$(pacman -Qq | grep 'hplip' -m1)" == "hplip" ]] && \
[[ "$(vercmp $(pacman -Q | grep 'hplip' -m1 | cut -d' ' -f2) 1:3.20.3-2)" -le 0 ]]; then
[[ "$(vercmp $(pacman -Q | grep 'hplip' -m1 | cut -d' ' -f2) 1:3.20.3-2)" -lt 0 ]]; then
msg "Fixing file conflicts for 'hplip' update for you ..."
rm /var/lib/pacman/db.lck &> /dev/null
pacman -S hplip --noconfirm --overwrite /usr/share/hplip/\*
......@@ -52,7 +52,7 @@ post_upgrade() {
# Fix firewalld 0.8.1-2 upgrade
if [[ "$(pacman -Qq | grep 'firewalld' -m1)" == "firewalld" ]] && \
[[ "$(vercmp $(pacman -Q | grep 'firewalld' -m1 | cut -d' ' -f2) 0.8.1-2)" -le 0 ]]; then
[[ "$(vercmp $(pacman -Q | grep 'firewalld' -m1 | cut -d' ' -f2) 0.8.1-2)" -lt 0 ]]; then
msg "Fixing file conflicts for 'firewalld' update for you ..."
rm /var/lib/pacman/db.lck &> /dev/null
pacman -S firewalld --noconfirm --overwrite /usr/lib/python3.8/site-packages/firewall/\*
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment