Commit 3b806753 authored by Bernhard Landauer's avatar Bernhard Landauer

correction

parent d04a2ee8
......@@ -6,7 +6,7 @@
pkgname=manjaro-system
pkgver=$(date +%Y%m%d)
pkgrel=1
pkgrel=3
pkgdesc="Manjaro Linux System - Update script"
arch=('any')
url="http://www.manjaro.org"
......
......@@ -41,14 +41,16 @@ detectDE()
}
post_upgrade() {
# Fix systemd upgrade with systemd 239.303 installed
if [[ "$(vercmp $(pacman -Q | grep 'systemd' -m1 | cut -d' ' -f2) 239.6)" -gt 0 ]] && libidn2_version < 2.1.0-1 ; then
msg "Your system has an unsupported systemd package. Downgrading it now ..."
rm /var/lib/pacman/db.lck &> /dev/null
pacman -Syyuu
else
msg "Your system is OK, continuing normal system upgrade ..."
fi
# Fix systemd upgrade with systemd 239.303 installed
if [[ "$(vercmp $(pacman -Q | grep 'systemd' -m1 | cut -d' ' -f2) 239.6)" -gt 0 ]]; then
if [[ "$(vercmp $(pacman -Q | grep 'libidn2' -m1 | cut -d' ' -f2) 2.1.0-1)" -lt 0 ]]; then
msg "Your system has an unsupported systemd package. Downgrading it now ..."
rm /var/lib/pacman/db.lck &> /dev/null
pacman --noconfirm -Syyuu
else
msg "Your system is OK, continuing normal system upgrade ..."
fi
fi
# Fix dunst upgrading
if [ "$(pacman -Qq | grep 'dunstify' -m1)" == "dunstify" ]; then
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment