Commit d04a2ee8 authored by Philip Müller's avatar Philip Müller

[pkg-upd] force downgrade when systemd is 239.303

parent 438a0b8d
......@@ -6,7 +6,7 @@
pkgname=manjaro-system
pkgver=$(date +%Y%m%d)
pkgrel=2
pkgrel=1
pkgdesc="Manjaro Linux System - Update script"
arch=('any')
url="http://www.manjaro.org"
......
......@@ -41,6 +41,15 @@ detectDE()
}
post_upgrade() {
# Fix systemd upgrade with systemd 239.303 installed
if [[ "$(vercmp $(pacman -Q | grep 'systemd' -m1 | cut -d' ' -f2) 239.6)" -gt 0 ]] && libidn2_version < 2.1.0-1 ; then
msg "Your system has an unsupported systemd package. Downgrading it now ..."
rm /var/lib/pacman/db.lck &> /dev/null
pacman -Syyuu
else
msg "Your system is OK, continuing normal system upgrade ..."
fi
# Fix dunst upgrading
if [ "$(pacman -Qq | grep 'dunstify' -m1)" == "dunstify" ]; then
if [ "$(vercmp $(pacman -Q | grep 'dunstify' -m1 | cut -d' ' -f2) 1.3.2-1)" -le 0 ]; then
......
  • @philm or if not present @fhdk
    libidn2_version < 2.1.0-1 libidn2_version not exist its pacman-Q | grep ... | cut ...

    more style

    if [[ "$(vercmp $(pacman -Q | grep 'systemd' -m1 | cut -d' ' -f2) 239.6)" -gt 0 ]] ; then
        if [[ "$(vercmp $(pacman -Q | grep 'libidn2' -m1 | cut -d' ' -f2) 2.1.0-1)" -lt 0 ]]; then
            echo "downgrade"
        fi
    fi
    Edited by patrick
  • Script not work:

    systemd 239.303-1 Synchronizing package databases... Starting full system upgrade... Warning: lib32-systemd: local (239.303-1) is newer than multilib (239.6-4) Warning: libsystemd: local (239.303-1) is newer than core (239.6-4) Warning: systemd: local (239.303-1) is newer than core (239.6-4) Warning: systemd-sysvcompat: local (239.303-1) is newer than core (239.6-4) Resolving dependencies... Checking inter-conflicts... Warning: dependency cycle detected: Warning: bashrc-manjaro will be installed before its bash dependency Resolving dependencies... Checking inter-conflicts... Downloading manjaro-system (20190124-1-any)... Checking keyring... Checking integrity... Loading packages files... Checking file conflicts... Checking available disk space... Upgrading manjaro-system (20190105-2 -> 20190124-1)... Configuring manjaro-system... /tmp/alpm_L77IXc/.INSTALL: line 45: 2.1.0-1: No such file or directory [1;1m[1;32m==>[1;0m[1;1m Your system is OK, continuing normal system upgrade ...[1;0m Warning: lib32-systemd: local (239.303-1) is newer than multilib (239.6-4) Warning: libsystemd: local (239.303-1) is newer than core (239.6-4) Warning: systemd: local (239.303-1) is newer than core (239.6-4) Warning: systemd-sysvcompat: local (239.303-1) is newer than core (239.6-4) Resolving dependencies...

    Please add to pacman -Syyu --noconfirm for GUI users

  • hopefully fixed with 3b806753

Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment