# Maintainer: Dan Johansen <strit@manjaro.org>
# Contributor: Helmut Stult

pkgname=manjaro-arm-installer
pkgver=1.5.3
pkgrel=1
pkgdesc="Scripts to install Manjaro ARM directly to SD/eMMC cards"
arch=('x86_64' 'aarch64')
url="https://gitlab.manjaro.org/manjaro-arm/applications/manjaro-arm-installer"
license=('GPL3')
depends_x86_64=('dialog'
                'gawk'
                'git'
                'libarchive'
                'qemu-user-static-binfmt'
                'parted'
                'wget'
                'openssl'
                'dosfstools'
                'polkit')
depends_aarch64=('dialog'
                 'gawk'
                 'git'
                 'libarchive'
                 'parted'
                 'wget'
                 'openssl'
                 'dosfstools'
                 'polkit')
optdepends=('btrfs-progs: btrfs filesystem utilities'
            'f2fs-tools: f2fs filesystem utilities'
            'cryptsetup: encryption support')
#optdepends_x86_64+=('grub-efi-arm64: for generic-efi support (only needed when script is run from other architectures than aarch64)') # AUR
install="$pkgname.install"
source=("$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
sha256sums=('7595ecc5201052c91ddb1cf44632adbe3ab61325276c730dd1d235a27f7a02e7')

package() {
    cd $pkgname-$pkgver
    install -Dm755 $pkgname $pkgdir/usr/bin/$pkgname
}