Commit 97f4e4e1 authored by guinux's avatar guinux

add version file

parent 981a2392
......@@ -17,8 +17,6 @@
* along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
const string VERSION = "6.5.0";
namespace Pamac {
[DBus (name = "org.manjaro.pamac.user")]
interface UserDaemon : Object {
......@@ -548,7 +546,7 @@ namespace Pamac {
}
void display_version () {
stdout.printf ("Pamac v%s\n", VERSION);
stdout.printf ("Pamac %s\n", VERSION);
}
void display_help () {
......@@ -719,7 +717,7 @@ namespace Pamac {
}
void display_reinstall_help () {
stdout.printf (dgettext (null, "Reinstall packages from the repositories"));
stdout.printf (dgettext (null, "Reinstall packages"));
stdout.printf ("\n\n");
stdout.printf ("pamac reinstall <%s>".printf ("%s,%s".printf (dgettext (null, "package(s)"), dgettext (null, "group(s)"))));
stdout.printf ("\n\n");
......@@ -1526,7 +1524,7 @@ namespace Pamac {
user_daemon.get_updates_finished.disconnect (on_get_updates_for_sysupgrade_finished);
uint updates_nb = updates.repos_updates.length + updates.aur_updates.length;
if (updates_nb == 0) {
stdout.printf ("%s\n", dgettext (null, "Your system is up-do-date"));
stdout.printf ("%s\n", dgettext (null, "Your system is up-to-date"));
} else {
// special status when updates are available
cmd.set_exit_status (100);
......
......@@ -17,8 +17,6 @@
* along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
const string VERSION = "6.4.0";
namespace Pamac {
class ActivableCellRendererPixbuf : Gtk.CellRendererPixbuf {
......
......@@ -35,7 +35,7 @@ transaction_sources = ['transaction.vala', 'choose_provider_dialog.vala', 'trans
preferences_sources = ['preferences_dialog.vala', 'choose_ignorepkgs_dialog.vala']
executable('pamac',
sources: ['cli.vala', 'common.vala', 'package.vala', 'pamac_config.vala'],
sources: [common_sources, 'version.vala','cli.vala'],
dependencies: [gio, posix, math],
vala_args: [common_vala_args, '--pkg=linux'],
c_args: common_c_args,
......@@ -89,7 +89,7 @@ libpamac = library('pamac',
libpamac_dep = declare_dependency(link_with: libpamac)
executable('pamac-manager',
sources: ['history_dialog.vala', 'manager_window.vala', 'manager.vala', manager_resources],
sources: ['version.vala', 'history_dialog.vala', 'manager_window.vala', 'manager.vala', manager_resources],
dependencies: [vala_deps, gtk3, gdk3, gdk_pixbuf2, libsoup, libpamac_dep],
vala_args: common_vala_args,
c_args: common_c_args,
......
const string VERSION = "6.5.0";
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment