Skip to content
Snippets Groups Projects
Commit 305a4ce7 authored by Philip Müller's avatar Philip Müller
Browse files

[pkg-upd] 0_20200520-1

parents
No related branches found
No related tags found
No related merge requests found
Pipeline #1827 failed
### Generic CI Template for chrootbuild
#
#
# Usage: chrootbuild [options]
#
# -b <branch> Branch to use:
# (unstable/testing/stable-staging/stable;
# arm-unstable/arm-testing/arm-stable)
# default: unstable / arm-unstable
# -c Start with clean chroot fs
# -h This help
# -i <pkg> Install package(s) to chroot fs
# (for multiple packages repeat -i flag)
# -l <list> List(s) to build
# (for multiple lists repeat -l flag)
# -n Install built pkg to chroot fs
# -p <pkg> Package(s) to build
# (for multiple packages repeat -p flag)
# -r Remove previously built packages in $PKGDEST
# -s Sign package(s)
package:
tags:
- aarch64
script:
# build pkg via chrootbuild
- export PKG=${PWD##*/}
- cd ..
- sudo chrootbuild -cp $PKG
- mv -v ./*.pkg.tar.* $PKG
artifacts:
paths:
- ./*.pkg.tar.*
expire_in: 1 week
PKGBUILD 0 → 100644
# Maintainer: Danct12 <danct12@disroot.org>
pkgname=anbox-image-aarch64
pkgver=0_20200520
pkgrel=5
pkgdesc="Anbox image for ARM64"
arch=(aarch64)
url="https://anbox.postmarketos.org"
license=('custom')
depends=(anbox)
makedepends=(squashfs-tools)
provides=(anbox-image)
_fdroidver=1007051
_fdroid="org.fdroid.fdroid_$_fdroidver.apk"
_fdroidprivver=2110
_fdroidpriv="org.fdroid.fdroid.privileged_$_fdroidprivver.apk"
source=(android.img::http://anbox.postmarketos.org/android-7.1.2_r39-anbox_arm64-userdebug.img
https://f-droid.org/repo/$_fdroid
https://f-droid.org/repo/$_fdroidpriv
SimpleKeyboard.apk::https://f-droid.org/repo/rkr.simplekeyboard.inputmethod_73.apk
network-fix.patch
display_settings.xml)
prepare() {
mkdir -p ./squashfs
# Decompressing the image
unsquashfs -f -d ./squashfs android.img
cd ./squashfs
patch -p1 -N < ../network-fix.patch
# remove su, it's broken and less apps will refuse to start
rm -v system/xbin/su
# Install FDroid
mkdir system/app/FDroid
mkdir system/priv-app/FDroid
# install -Dm 0644 doesn't work as it copies the symlink, hence cp
cp -L "$srcdir"/$_fdroid system/app/FDroid/$_fdroid
cp -L "$srcdir"/$_fdroidpriv system/priv-app/FDroid/$_fdroidpriv
chmod 0644 system/app/FDroid/$_fdroid
chmod 0644 system/priv-app/FDroid/$_fdroidpriv
# Install SimpleKeyboard
mkdir system/app/SimpleKeyboard
cp -L "$srcdir"/SimpleKeyboard.apk system/app/SimpleKeyboard/SimpleKeyboard.apk
chmod 0644 system/app/SimpleKeyboard/SimpleKeyboard.apk
}
package() {
mksquashfs "$srcdir"/squashfs "$srcdir"/android-fdroid.img -comp xz -no-xattrs
install -Dm600 "$srcdir"/android-fdroid.img "$pkgdir"/var/lib/anbox/android.img
# display overscan
install -Dm666 "$srcdir"/display_settings.xml "$pkgdir"/var/lib/anbox/data/system/display_settings.xml
}
md5sums=('5c2e2a5fc1e6a388f6949b3df65b5c0c'
'a5ba31782253a1a7c8f58faf1b75156d'
'b8c42726bd6c8f3931e8a01890ce47b4'
'2c2663fc448ec1071503690893ed29c5'
'1ef3b59fb14bbb7d17236af393d27474'
'363e812b6efcaf579da46affc7cd321f')
<?xml version='1.0' encoding='utf-8' standalone='yes' ?>
<display-settings>
<display name="local:0" overscanTop="35" overscanBottom="35" />
</display-settings>
--- a/anbox-init.sh
+++ b/anbox-init.sh
@@ -36,5 +36,12 @@ prepare_filesystem &
echo "Waiting for filesystem being prepared ..."
wait $!
+(
+while ! ping -c 1 192.168.250.1; do
+ sleep 1
+ ip route add default via 192.168.250.1
+done
+) >/dev/null 2>&1 &
+
echo "Starting real init now ..."
exec /init
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment