Skip to content
Snippets Groups Projects
Verified Commit 4405d9c4 authored by Dan Johansen's avatar Dan Johansen
Browse files

sync with Arch Linux ARM PKGBUILD, update to 20.0


Signed-off-by: default avatarDan Johansen <strit@manjaro.org>
parent 57d5f4be
No related branches found
No related tags found
1 merge request!1sync with Arch Linux ARM PKGBUILD, update to 20.0
Pipeline #10780 passed
......@@ -23,9 +23,6 @@ package:
tags:
- aarch64
- bigbuilds
- xlarge
# - spikerguy-honeycomb
- fosshost
script:
# build pkg via chrootbuild
- export PKG=${PWD##*/}
......
From 11071b94eff58eeaf69f2b81afe317b72cd22b54 Mon Sep 17 00:00:00 2001
From: graysky <therealgraysky@proton.me>
Date: Sat, 7 May 2022 06:10:06 -0400
Subject: [PATCH 1/2] mcpu=cortex-xxx application to ffmpeg
Get build system to patch ffmpeg source removing the -march= flag
---
cmake/modules/FindFFMPEG.cmake | 1 +
1 file changed, 1 insertion(+)
diff --git a/cmake/modules/FindFFMPEG.cmake b/cmake/modules/FindFFMPEG.cmake
index 9ce807c..a18b21c 100644
--- a/cmake/modules/FindFFMPEG.cmake
+++ b/cmake/modules/FindFFMPEG.cmake
@@ -279,6 +279,7 @@ if(NOT FFMPEG_FOUND)
${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/FindGnuTls.cmake
<SOURCE_DIR> &&
patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0001-rpi-Add-hevc-acceleration.patch &&
+ patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch &&
echo "########################################## patched ffmpeg ##############################"
)
--
2.36.0
From 9bc4045471dd0f6a23023db6801173b0c624e127 Mon Sep 17 00:00:00 2001
From: graysky <therealgraysky@proton.me>
Date: Sat, 7 May 2022 06:11:27 -0400
Subject: [PATCH 2/2] add dav1d patch to build system
---
cmake/modules/FindFFMPEG.cmake | 1 +
1 file changed, 1 insertion(+)
diff --git a/cmake/modules/FindFFMPEG.cmake b/cmake/modules/FindFFMPEG.cmake
index a18b21c..fb7326f 100644
--- a/cmake/modules/FindFFMPEG.cmake
+++ b/cmake/modules/FindFFMPEG.cmake
@@ -280,6 +280,7 @@ if(NOT FFMPEG_FOUND)
<SOURCE_DIR> &&
patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0001-rpi-Add-hevc-acceleration.patch &&
patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch &&
+ patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0003-add-dav1d-patch-to-build-system.patch &&
echo "########################################## patched ffmpeg ##############################"
)
--
2.36.0
# Maintainer: Dan Johansen <strit@manjaro.org>
# Maintainer: Ray Sherwin <slick517d@gmail.com>
# Contributor graysky <graysky AT archlinux DOT org>
# Contributor graysky <therealgraysky AT proton DOT me>
# Contributor: BlackIkeEagle < ike DOT devolder AT gmail DOT com>
# Contributor Kevin Mihelich <kevin@archlinuxarm.org>
# Contributor BlackIkeEagle < ike DOT devolder AT gmail DOT com >
......@@ -14,51 +12,55 @@ pkgname=(
'kodi-rpi'
'kodi-rpi-eventclients' 'kodi-rpi-tools-texturepacker' 'kodi-rpi-dev'
)
pkgver=19.4.1
pkgrel=5
_commit=51a36cca9f6dd2bc717e41153fb2d0aa9caf11ca
arch=('armv7h' 'aarch64')
url="https://github.com/graysky2/xbmc/tree/gs-gbm_matrix"
_commitnumber=61945
_commit=2464903eb19ac84f8883a78f4f8cb626bed225d7
# set this to anything to build with clang
# recommend manually setting -DUSE_LTO=OFF to -DUSE_LTO=$(nproc) in build()
_clangbuild=
pkgver=20.0
pkgrel=7
arch=('aarch64' 'armv7h')
url="https://github.com/graysky2/xbmc/tree/gs-gbm_nexus"
license=('GPL2')
makedepends=(
'afpfs-ng' 'bluez-libs' 'cmake' 'curl' 'dav1d' 'doxygen' 'git' 'glew'
'gperf' 'hicolor-icon-theme' 'java-runtime' 'libaacs' 'libass'
'gperf' 'hicolor-icon-theme' 'java-runtime' 'fmt' 'libaacs' 'libass'
'libbluray' 'libcdio' 'libcec-rpi' 'libgl' 'mariadb-libs' 'libmicrohttpd'
'libmodplug' 'libmpeg2' 'libnfs' 'libplist' 'libpulse'
'libxrandr' 'libxslt' 'lirc' 'lzo' 'mesa' 'nasm'
'python-pycryptodomex' 'python-pillow' 'python-pybluez'
'python-simplejson' 'shairplay' 'smbclient' 'taglib' 'tinyxml' 'swig'
'upower' 'giflib' 'rapidjson' 'ghostscript' 'meson' 'gtest' 'graphviz'
'libinput' 'libxkbcommon' 'flatbuffers'
'pipewire' 'python-pycryptodomex' 'python-pillow' 'python-pybluez'
'python-simplejson' 'shairplay' 'smbclient' 'sndio' 'spdlog' 'taglib'
'tinyxml' 'swig' 'upower' 'giflib' 'rapidjson' 'ghostscript' 'meson' 'gtest'
'graphviz' 'libinput' 'libxkbcommon'
)
_codename=Matrix
[[ -n "$_clangbuild" ]] && makedepends+=('clang' 'lld' 'llvm')
_codename=Nexus
_init_version=1.136
_libdvdcss_version="1.4.2-Leia-Beta-5"
_libdvdnav_version="6.0.0-Leia-Alpha-3"
_libdvdread_version="6.0.0-Leia-Alpha-3"
_ffmpeg_version="4.3.2-$_codename-19.2"
_fmt_version="6.1.2"
_spdlog_version="1.5.0"
_crossguid_version="8f399e8bd4"
_libdvdcss_version="1.4.3-Next-Nexus-Alpha2-2"
_libdvdnav_version="6.1.1-Next-Nexus-Alpha2-2"
_libdvdread_version="6.1.3-Next-Nexus-Alpha2-2"
_ffmpeg_version="4.4.1-Nexus-Alpha1"
_crossguid_version="ca1bf4b810e2d188d04cb6286f957008ee1b7681"
_fstrcmp_version="0.7.D001"
_libudfread_version="1.1.0"
_flatbuffers_version="2.0.0"
_libudfread_version="1.1.2"
source=(
"xbmc-$pkgver.tar.gz::https://github.com/graysky2/xbmc/archive/$_commit.tar.gz"
"xbmc-$pkgver.${_commit:0:10}.tar.gz::https://github.com/graysky2/xbmc/archive/$_commit.tar.gz"
"libdvdcss-$_libdvdcss_version.tar.gz::https://github.com/xbmc/libdvdcss/archive/$_libdvdcss_version.tar.gz"
"libdvdnav-$_libdvdnav_version.tar.gz::https://github.com/xbmc/libdvdnav/archive/$_libdvdnav_version.tar.gz"
"libdvdread-$_libdvdread_version.tar.gz::https://github.com/xbmc/libdvdread/archive/$_libdvdread_version.tar.gz"
"ffmpeg-$_ffmpeg_version.tar.gz::https://github.com/xbmc/FFmpeg/archive/$_ffmpeg_version.tar.gz"
"http://mirrors.kodi.tv/build-deps/sources/fmt-$_fmt_version.tar.gz"
"http://mirrors.kodi.tv/build-deps/sources/crossguid-$_crossguid_version.tar.gz"
"http://mirrors.kodi.tv/build-deps/sources/fstrcmp-$_fstrcmp_version.tar.gz"
"http://mirrors.kodi.tv/build-deps/sources/spdlog-$_spdlog_version.tar.gz"
"http://mirrors.kodi.tv/build-deps/sources/libudfread-$_libudfread_version.tar.gz"
"https://mirrors.kodi.tv/build-deps/sources/crossguid-$_crossguid_version.tar.gz"
"https://mirrors.kodi.tv/build-deps/sources/fstrcmp-$_fstrcmp_version.tar.gz"
"https://mirrors.kodi.tv/build-deps/sources/flatbuffers-$_flatbuffers_version.tar.gz"
"https://mirrors.kodi.tv/build-deps/sources/libudfread-$_libudfread_version.tar.gz"
"ArchARM-kodi-init-v$_init_version.tar.gz::https://github.com/graysky2/kodi-standalone-service/archive/v$_init_version.tar.gz"
kodi.config.txt
build-fix-for-dav1d-1.0.0.patch
use-mcpu-avoiding-march-and-mtune.patch
0001-mcpu-cortex-application-to-ffmpeg.patch
0002-add-dav1d-patch-to-build-system.patch
"https://github.com/xbmc/xbmc/pull/22714.patch"
)
backup=(boot/kodi.config.txt etc/conf.d/kodi-standalone)
noextract=(
......@@ -66,49 +68,35 @@ noextract=(
"libdvdnav-$_libdvdnav_version.tar.gz"
"libdvdread-$_libdvdread_version.tar.gz"
"ffmpeg-$_ffmpeg_version.tar.gz"
"fmt-$_fmt_version.tar.gz"
"spdlog-$_spdlog_version.tar.gz"
"crossguid-$_crossguid_version.tar.gz"
"fstrcmp-$_fstrcmp_version.tar.gz"
"flatbuffers-$_flatbuffers_version.tar.gz"
"libudfread-$_libudfread_version.tar.gz"
)
sha256sums=('ea57f7d2339bede8086082865afbb47c953f195dbfbaf54c43aeb4b46b8f9f2e'
'38816f8373e243bc5950449b4f3b18938c4e1c59348e3411e23f31db4072e40d'
'071e414e61b795f2ff9015b21a85fc009dde967f27780d23092643916538a57a'
'a30b6aa0aad0f2c505bc77948af2d5531a80b6e68112addb4c123fca24d5d3bf'
'58fe3a3ba38d2b30cd8bfe40e1b3bf82296b258627d0740c284af29f0c8a6655'
'1cafc80701b746085dddf41bd9193e6d35089e1c6ec1940e037fcb9c98f62365'
'3d77d09a5df0de510aeeb940df4cb534787ddff3bb1828779753f5dfa1229d10'
sha256sums=('82a64bc1eb2112679db74a49c1ed1a6e5ddcad1334b71320f48ad1089475b8d3'
'f38c4a4e7a4f4da6d8e83b8852489aa3bb6588a915dc41f5ee89d9aad305a06e'
'584f62a3896794408d46368e2ecf2c6217ab9c676ce85921b2d68b8961f49dfc'
'719130091e3adc9725ba72df808f24a14737a009dca5a4c38c601c0c76449b62'
'abbce62231baffe237e412689c71ffe01bfc83135afd375f1e538caae87729ed'
'6be27e0b3a4907f0cd3cfadec255ee1b925569e1bd06e67a4d2f4267299b69c4'
'e4018e850f80700acee8da296e56e15b1eef711ab15157e542e7d7e1237c3476'
'b38e0bbef7faac2b82fed550a0c19b0d4e7f6737d5321d4fd8f216b80f8aee8a'
'5ad9f95c53e8f29853c1fefa0a20a301be4045e2c7ae49d1164bc74d94155627'
'9ddb9031798f4f8754d00fca2f1a68ecf9d0f83dfac7239af1311e4fd9a565c4'
'2bf16726ac98d093156195bb049a663e07d3323e079c26912546f4e05c77bac5'
'b94c70baa45e30346224ceecfab031dd183e09303b1f97d6522f9941da9b0067'
'23f105f914f3372afa432251b69c7601e50c22d1a88168185105ee859005f5cd'
'bcde6299a805430c3ca1f2807101edc7001e77b1934088db9057f74d9a9dd8f6'
'c226f082349e6442b8920e1108005792c42b9461f7cec0e1576ae079520eed13'
'afe90ded82e70af8e5680347a72edcbdc1dcae498083a90cc453dce00b665fce'
'7f6e8e5c2084ab88d10ab2c55982212a8c6cbcf4101079be343763127f129a22')
'9ce6051a2157e6b677090f201d98870a33db6c90c91dc0d480a87fb7ab84e3e5'
'677745404a2b000674c74eefe1ce345331260906d3bc449c6fe79c8f4c014845')
prepare() {
[[ -d kodi-build ]] && rm -rf kodi-build
mkdir "$srcdir/kodi-build"
cd "xbmc-$_commit"
# put patches in source tree so kodi build system can pick it up
cp ../use-mcpu-avoiding-march-and-mtune.patch \
tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch
cp ../build-fix-for-dav1d-1.0.0.patch \
tools/depends/target/ffmpeg/0003-add-dav1d-patch-to-build-system.patch
# patch kodi build system to apply the patches we just copied over
patch -p1 -i ../0001-mcpu-cortex-application-to-ffmpeg.patch
patch -p1 -i ../0002-add-dav1d-patch-to-build-system.patch
# fix nfsv4 lockout
patch -p1 -i ../22714.patch
}
build() {
cd "$srcdir/kodi-build"
cd kodi-build
# -march= defined in /etc/makepkg.conf will override the value for -mcpu we
# uses here so unset them and redefine below
......@@ -125,58 +113,87 @@ build() {
CFLAGS="-mcpu=cortex-a53"
fi
export CFLAGS+=" -O2 -pipe -fstack-protector-strong -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security -fstack-clash-protection"
export CXXFLAGS+="${CFLAGS} -Wp,-D_GLIBCXX_ASSERTIONS"
CFLAGS+=" -O2 -pipe -fstack-protector-strong -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security -fstack-clash-protection"
CXXFLAGS+="${CFLAGS} -Wp,-D_GLIBCXX_ASSERTIONS"
if [[ -n "$_clangbuild" ]]; then
export CC=clang CXX=clang++
# depending on your build system, optionally redefine DISTCC_HOSTS
# since current toolchain does not include clang support x86_64 volunteers
#unset DISTCC_HOSTS
#export DISTCC_HOSTS="localhost/5 10.0.1.103/5:3636"
fi
_args=(
-DCMAKE_BUILD_TYPE=Release
-DCMAKE_INSTALL_PREFIX=/usr
-DCMAKE_INSTALL_LIBDIR=/usr/lib
-DUSE_LTO=OFF
-DVERBOSE=ON
-DENABLE_LDGOLD=OFF
-DENABLE_AIRTUNES=ON
-DENABLE_AVAHI=ON
-DENABLE_BLURAY=ON
-DENABLE_CEC=ON
-DENABLE_DBUS=ON
-DENABLE_DVDCSS=ON
-DENABLE_EVENTCLIENTS=ON
-DENABLE_MICROHTTPD=ON
-DENABLE_MYSQLCLIENT=ON
-DENABLE_NFS=ON
-DENABLE_OPTICAL=ON
-DENABLE_SMBCLIENT=ON
-DENABLE_UDEV=ON
-DENABLE_UPNP=ON
-DENABLE_VAAPI=OFF
-DENABLE_VDPAU=OFF
-DENABLE_XSLT=ON
-DENABLE_LIRCCLIENT=ON
-DENABLE_INTERNAL_FFMPEG=ON
-DENABLE_INTERNAL_FMT=ON
-DENABLE_INTERNAL_SPDLOG=ON
-DENABLE_INTERNAL_CROSSGUID=ON
-DENABLE_INTERNAL_FSTRCMP=ON
-DENABLE_INTERNAL_FLATBUFFERS=ON
-DENABLE_INTERNAL_UDFREAD=ON
-DENABLE_MYSQLCLIENT=ON
-DENABLE_VAAPI=OFF
-DENABLE_VDPAU=OFF
-Dlibdvdcss_URL="$srcdir/libdvdcss-$_libdvdcss_version.tar.gz"
-Dlibdvdnav_URL="$srcdir/libdvdnav-$_libdvdnav_version.tar.gz"
-Dlibdvdread_URL="$srcdir/libdvdread-$_libdvdread_version.tar.gz"
-DFFMPEG_URL="$srcdir/ffmpeg-$_ffmpeg_version.tar.gz"
-DFMT_URL="$srcdir/fmt-$_fmt_version.tar.gz"
-DSPDLOG_URL="$srcdir/spdlog-$_spdlog_version.tar.gz"
-DCROSSGUID_URL="$srcdir/crossguid-$_crossguid_version.tar.gz"
-DFSTRCMP_URL="$srcdir/fstrcmp-$_fstrcmp_version.tar.gz"
-DFLATBUFFERS_URL="$srcdir/flatbuffers-$_flatbuffers_version.tar.gz"
-DUDFREAD_URL="$srcdir/libudfread-$_libudfread_version.tar.gz"
-DAPP_RENDER_SYSTEM=gles
-DCORE_PLATFORM_NAME="x11 gbm"
)
# https://github.com/google/flatbuffers/issues/7404
CXXFLAGS+=' -Wno-error=restrict'
echo "building kodi"
cmake "${_args[@]}" ../"xbmc-$_commit"
make
}
package_kodi-rpi() {
pkgdesc="Media player and entertainment hub for Raspberry Pi 3/4/400, gbm_matrix fork"
pkgdesc="Media player and entertainment hub with hw accel for RPi 3/4/400, gbm_nexus fork"
depends=(
'bluez-libs' 'curl' 'dav1d' 'desktop-file-utils' 'hicolor-icon-theme'
'bluez-libs' 'curl' 'dav1d' 'desktop-file-utils' 'hicolor-icon-theme' 'fmt'
'lcms2' 'libass' 'libbluray' 'libcdio' 'libcec-rpi' 'libmicrohttpd' 'libnfs'
'libplist' 'libpulse' 'libxslt' 'lirc' 'mariadb-libs' 'mesa'
'python-pillow' 'python-pycryptodomex' 'python-simplejson'
'shairplay' 'smbclient' 'sqlite' 'taglib' 'tinyxml'
'libinput' 'libxkbcommon' 'polkit' 'linux>=5.4.35' 'lzo' 'flatbuffers'
'libplist' 'libpulse' 'libxslt' 'lirc' 'mariadb-libs'
'mesa' 'libpipewire' 'python-pillow' 'python-pycryptodomex'
'python-simplejson' 'shairplay' 'smbclient' 'sndio' 'spdlog' 'sqlite'
'taglib' 'tinyxml' 'libxkbcommon' 'polkit' 'linux>=5.4.35' 'lzo' 'libinput'
'pcre'
)
[[ -n "$_clangbuild" ]] && depends+=('glu')
optdepends=(
'afpfs-ng: Apple shares support'
'bluez: Blutooth support'
'linux-rpi4: HW accelerated decoding'
'linux-rpi: HW accelerated decoding'
'python-pybluez: Bluetooth support'
'pulseaudio: PulseAudio support'
'pipewire: PipeWire support'
)
install='kodi.install'
provides=('xbmc' "kodi=${pkgver}" "kodi-common=${pkgver}")
......@@ -198,7 +215,7 @@ package_kodi-rpi() {
# setup video drivers for kodi-gbm
install -Dm0644 "$srcdir/kodi.config.txt" "$pkgdir/boot/kodi.config.txt"
# rpi4 wants 512 MB of memory
# rpi4 wants 512 MB of memory ... might be a problem or rpi3?
sed -i 's/@@@/512/' "$pkgdir/boot/kodi.config.txt"
_initshit="$srcdir/kodi-standalone-service-$_init_version/arm"
......@@ -220,10 +237,14 @@ package_kodi-rpi() {
# man page
install -Dm0644 "$_initshit/doc/kodi.service.1" "$pkgdir/usr/share/man/man1/kodi.service.1"
# avoid error <general>: GetDirectory - Error getting /usr/lib/kodi/addons
# https://bugs.archlinux.org/task/77366
mkdir -p "$pkgdir"/usr/lib/kodi/addons
}
package_kodi-rpi-eventclients() {
pkgdesc="Kodi Event Clients for Raspberry Pi 3/4/400, gbm_matrix fork"
pkgdesc="Kodi Event Clients"
provides=("kodi-eventclients=${pkgver}")
conflicts=('kodi-rbp-eventclients' 'kodi-rbp3-eventclients' 'kodi-rbp4-eventclients' 'kodi-rpi-legacy-eventclients')
replaces=('kodi-rbp4-eventclients')
......@@ -247,7 +268,7 @@ package_kodi-rpi-eventclients() {
}
package_kodi-rpi-tools-texturepacker() {
pkgdesc="Kodi Texturepacker Tool for Raspberry Pi 3/4/400, gbm_matrix fork"
pkgdesc="Kodi Texturepacker Tool"
depends=('libpng' 'giflib' 'libjpeg-turbo' 'lzo')
conflicts=('kodi-rbp-tools-texturepacker' 'kodi-rbp3-tools-texturepacker' 'kodi-rbp4-tools-texturepacker' 'kodi-rpi-legacy-tools-texturepacker')
replaces=('kodi-rbp4-tools-texturepacker')
......@@ -265,7 +286,7 @@ package_kodi-rpi-tools-texturepacker() {
}
package_kodi-rpi-dev() {
pkgdesc="Kodi dev files for Raspberry Pi 3/4/400, gbm_matrix fork"
pkgdesc="Kodi dev files"
depends=('kodi')
conflicts=('kodi-rbp-dev' 'kodi-rbp3-dev' 'kodi-rbp4-dev' 'kodi-rpi-legacy-dev')
replaces=('kodi-rbp4-dev')
......
From 2546e1ed27f92a840a2cf319e3c1833799974cf1 Mon Sep 17 00:00:00 2001
From: BlackEagle <ike.devolder@gmail.com>
Date: Fri, 29 Apr 2022 14:33:12 +0200
Subject: [PATCH] add build fix for dav1d 1.0.0
Taken from https://github.com/FFmpeg/FFmpeg/commit/e204846ec16c1ab34c7f3a681734cf5190433018
add FF_DAV1D_VERSION_AT_LEAST
Extracted from https://github.com/FFmpeg/FFmpeg/commit/7ee17ec7e46afef0e0af20af196292ec75f50b62
Signed-off-by: BlackEagle <ike.devolder@gmail.com>
---
libavcodec/libdav1d.c | 24 ++++++++++++++++++++++--
1 file changed, 22 insertions(+), 2 deletions(-)
diff --git a/libavcodec/libdav1d.c b/libavcodec/libdav1d.c
index bbb3ec1e6c..08b4af8ac8 100644
--- a/libavcodec/libdav1d.c
+++ b/libavcodec/libdav1d.c
@@ -30,6 +30,9 @@
#include "decode.h"
#include "internal.h"
+#define FF_DAV1D_VERSION_AT_LEAST(x,y) \
+ (DAV1D_API_VERSION_MAJOR > (x) || DAV1D_API_VERSION_MAJOR == (x) && DAV1D_API_VERSION_MINOR >= (y))
+
typedef struct Libdav1dContext {
AVClass *class;
Dav1dContext *c;
@@ -140,6 +143,15 @@ static av_cold int libdav1d_init(AVCodecContext *c)
if (dav1d->operating_point >= 0)
s.operating_point = dav1d->operating_point;
+#if FF_DAV1D_VERSION_AT_LEAST(6,0)
+ if (dav1d->frame_threads || dav1d->tile_threads)
+ s.n_threads = FFMAX(dav1d->frame_threads, dav1d->tile_threads);
+ else
+ s.n_threads = FFMIN(threads, DAV1D_MAX_THREADS);
+ s.max_frame_delay = (c->flags & AV_CODEC_FLAG_LOW_DELAY) ? 1 : s.n_threads;
+ av_log(c, AV_LOG_DEBUG, "Using %d threads, %d max_frame_delay\n",
+ s.n_threads, s.max_frame_delay);
+#else
s.n_tile_threads = dav1d->tile_threads
? dav1d->tile_threads
: FFMIN(floor(sqrt(threads)), DAV1D_MAX_TILE_THREADS);
@@ -148,6 +160,7 @@ static av_cold int libdav1d_init(AVCodecContext *c)
: FFMIN(ceil(threads / s.n_tile_threads), DAV1D_MAX_FRAME_THREADS);
av_log(c, AV_LOG_DEBUG, "Using %d frame threads, %d tile threads\n",
s.n_frame_threads, s.n_tile_threads);
+#endif
res = dav1d_open(&dav1d->c, &s);
if (res < 0)
@@ -384,11 +397,18 @@ static av_cold int libdav1d_close(AVCodecContext *c)
return 0;
}
+#ifndef DAV1D_MAX_FRAME_THREADS
+#define DAV1D_MAX_FRAME_THREADS DAV1D_MAX_THREADS
+#endif
+#ifndef DAV1D_MAX_TILE_THREADS
+#define DAV1D_MAX_TILE_THREADS DAV1D_MAX_THREADS
+#endif
+
#define OFFSET(x) offsetof(Libdav1dContext, x)
#define VD AV_OPT_FLAG_VIDEO_PARAM | AV_OPT_FLAG_DECODING_PARAM
static const AVOption libdav1d_options[] = {
- { "tilethreads", "Tile threads", OFFSET(tile_threads), AV_OPT_TYPE_INT, { .i64 = 0 }, 0, DAV1D_MAX_TILE_THREADS, VD },
- { "framethreads", "Frame threads", OFFSET(frame_threads), AV_OPT_TYPE_INT, { .i64 = 0 }, 0, DAV1D_MAX_FRAME_THREADS, VD },
+ { "tilethreads", "Tile threads", OFFSET(tile_threads), AV_OPT_TYPE_INT, { .i64 = 0 }, 0, DAV1D_MAX_TILE_THREADS, VD | AV_OPT_FLAG_DEPRECATED },
+ { "framethreads", "Frame threads", OFFSET(frame_threads), AV_OPT_TYPE_INT, { .i64 = 0 }, 0, DAV1D_MAX_FRAME_THREADS, VD | AV_OPT_FLAG_DEPRECATED },
{ "filmgrain", "Apply Film Grain", OFFSET(apply_grain), AV_OPT_TYPE_BOOL, { .i64 = -1 }, -1, 1, VD },
{ "oppoint", "Select an operating point of the scalable bitstream", OFFSET(operating_point), AV_OPT_TYPE_INT, { .i64 = -1 }, -1, 31, VD },
{ "alllayers", "Output all spatial layers", OFFSET(all_layers), AV_OPT_TYPE_BOOL, { .i64 = 0 }, 0, 1, VD },
--
2.36.0
dtoverlay=vc4-kms-v3d,cma-@@@
dtoverlay=rpivid-v4l2
### leave this next entry blank as ensures dt parameters like dtparam=audio=on
### which could appear after "include kodi.config.txt" in /boot/config.txt are
### applied to the base dt instead of to the last dtoverlay loaded
......@@ -9,11 +8,7 @@ disable_fw_kms_setup=1
### RPi 4B/400 ONLY
### For 4k content @ 60 Hz refresh rate, uncomment hdmi_enable_4kp60=1
#
### If it breaks video output as detailed in the following bug, also uncomment
### force_turbo=1 see: https://github.com/raspberrypi/linux/issues/4446
#hdmi_enable_4kp60=1
#force_turbo=1
### uncomment to use the analog audio jack
### the 2nd option prevents crackling audio when HW accel decoding is active
......
......@@ -24,15 +24,6 @@ post_install() {
post_upgrade() {
post_install
# version 19.0-7 moves kodi.service to user.slice so warn users about data loss
if (($(vercmp 19.0-7 $2) > 0)); then
cat <<END
>>> kodi.service now runs in systemd's user.slice, see man kodi.service for
important info on how to reboot or shutdown the system to avoid data loss!
END
fi
}
post_remove() {
......
From 2e2417894ac5d35bc3d93b86c18f4df299f4d933 Mon Sep 17 00:00:00 2001
From: graysky <therealgraysky@proton.me>
Date: Sat, 12 Dec 2020 09:10:28 -0500
Subject: [PATCH] use -mcpu= avoiding -march and -mtune for armv7h
From what I understand, when building on ARM, it's best to avoid the -march=
flag and rather use -mcpu= flag due to differences in meaning on ARM vs x86[1].
Additionally, this patch avoids thousands of warns like the following when
building for armv7h:
cc1: warning: switch '-mcpu=cortex-a72' conflicts with '-march=armv8-a'
This is due to the way ffmpeg's configure script defines -march=armv8-a when it
encounters any cortex-a* passed to it.
for reference and to experiment:
untar ffmpeg, run ./configure, then inspect the output of ffbuild/config.mak and adjust:
kodi-build/build/ffmpeg/src/ffmpeg-build/ffmpeg-prefix/src/ffmpeg-build/ffbuild/config.mak
1. https://community.arm.com/developer/tools-software/tools/b/tools-software-ides-blog/posts/compiler-flags-across-architectures-march-mtune-and-mcpu
---
configure | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure b/configure
index 8569a60..0d3aafb 100755
--- a/configure
+++ b/configure
@@ -4948,7 +4948,7 @@ elif enabled arm; then
case $cpu in
armv*)
- cpuflags="-march=$cpu"
+ cpuflags="-mcpu=cortex-a53"
subarch=$(echo $cpu | sed 's/[^a-z0-9]//g')
;;
*)
--
2.29.2
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment