Skip to content
Snippets Groups Projects
Commit 2e91ab5e authored by Helmut Stult's avatar Helmut Stult
Browse files

[pkg-upd] 5.7.8-1

parent 0bcdfcea
No related branches found
No related tags found
No related merge requests found
......@@ -10,8 +10,8 @@ pkgname=('linux57' 'linux57-headers')
_kernelname=-MANJARO
_basekernel=5.7
_basever=57
_aufs=20200518
pkgver=5.7.7
_aufs=20200622
pkgver=5.7.8
pkgrel=1
arch=('x86_64')
url="http://www.kernel.org/"
......@@ -36,6 +36,8 @@ source=("https://www.kernel.org/pub/linux/kernel/v5.x/linux-${_basekernel}.tar.x
'aufs5-loopback.patch'
'aufs5-mmap.patch'
'aufs5-standalone.patch'
'lockdep-debug.patch'
'proc_mounts.patch'
'tmpfs-idr.patch'
'vfs-ino.patch'
# ARCH Patches
......@@ -66,15 +68,17 @@ source=("https://www.kernel.org/pub/linux/kernel/v5.x/linux-${_basekernel}.tar.x
'0012-bootsplash.patch'
'0013-bootsplash.patch')
sha256sums=('de8163bb62f822d84f7a3983574ec460060bf013a78ff79cd7c979ff1ec1d7e0'
'dc533b4b9756d417d59c2514237401d2c5d0814d13083b4f5736df48cf9312f4'
'eea2cb4ea7c2014b0daa6d702fc7087d017c55e6ea479434b1269626eda9fde5'
'2a4cad8a5a80280b74513370c696531e583085fb671238692fadf60bc2cc2f2e'
'b44d81446d8b53d5637287c30ae3eb64cae0078c3fbc45fcf1081dd6699818b5'
'018cb4826735b83715436d04063b66207b3d6f8f9516fa7e033ffa13364958c3'
'0cf385b91049106e2e737b7fcf749bbf3469a5179358bef3a21bf574639c12aa'
'54613b757f4765e24827833ecbd3e3b48d6bfa47484e558b0e2104808ab4b631'
'ba4d803d68e9f784b765dcc28c9315ae5ada55bde76d48fe9fa859e0b4f3c9e3'
'60198f61b1b42574db0130802b64cb4b4b5aee483fa92370959dcdfa8b18545a'
'b3ab078413fb0eca600a32a7ae5f61554fd709d4647a109320412828d36bea69'
'b3455e089e3ac499c0df4a47636aec6eed2b0be0a6e4c7af7aaccb7274dae5ce'
'a320441bd4540eaf6ed10bbcfb9714bd6d358852aacf0da63330c40a1ad3732c'
'2ccc807cc6f0fc21f8e23e2e9fd080eb1bc12c3450779e7025ebeaeee2ecffb4'
'842d2cb05d5796479654634a3cc6623513cefbfdf135a1471dbbfa994166ec14'
'499d25d110f9867e6aa3a9eb085005d7e59795ab4e0023d6fce21e7b8c21f383'
'3e45b6d925fc7490ce6597b7d353dd7a8e0681dd192e241f8c6491341673e30d'
'9bd3e02fb811fc285e0b250eb993e8a4a7ab12e73d200d90ad647cc28b17f374'
'0339a83249cf3fcfb0ddc9caf607fd0312c5b84f35445a543d46f21e2b38240b'
'9e7ce0431a786444e95e05dafde2d75387fb75d0709dcc807915d638879701cd'
'20abad2643c635210c925c3ce3a12eb31f813819d6e661c6d99d9cc3163fbef7'
'7685d526bbdbfa795986591a70071c960ff572f56d3501774861728a9df8664c'
......@@ -199,6 +203,10 @@ prepare() {
patch -Np1 -i "${srcdir}/aufs5-mmap.patch"
msg2 "aufs5-standalone"
patch -Np1 -i "${srcdir}/aufs5-standalone.patch"
msg2 "lockdep-debug"
patch -Np1 -i "${srcdir}/lockdep-debug.patch"
msg2 "proc_mounts"
patch -Np1 -i "${srcdir}/proc_mounts.patch"
msg2 "tmpfs-idr"
patch -Np1 -i "${srcdir}/tmpfs-idr.patch"
msg2 "vfs-ino"
......
......@@ -2,7 +2,7 @@ SPDX-License-Identifier: GPL-2.0
aufs5.x-rcN base patch
diff --git a/MAINTAINERS b/MAINTAINERS
index 091ec22c1a23..63a2784eaf01 100644
index 50659d76976b7..80f67140e4f70 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2946,6 +2946,19 @@ F: include/linux/audit.h
......@@ -26,7 +26,7 @@ index 091ec22c1a23..63a2784eaf01 100644
M: Miguel Ojeda Sandonis <miguel.ojeda.sandonis@gmail.com>
S: Maintained
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index da693e6a834e..0479902a0cd5 100644
index da693e6a834e5..0479902a0cd50 100644
--- a/drivers/block/loop.c
+++ b/drivers/block/loop.c
@@ -753,6 +753,24 @@ static int loop_change_fd(struct loop_device *lo, struct block_device *bdev,
......@@ -55,7 +55,7 @@ index da693e6a834e..0479902a0cd5 100644
static ssize_t loop_attr_show(struct device *dev, char *page,
diff --git a/fs/dcache.c b/fs/dcache.c
index b280e07e162b..046000653e4d 100644
index b280e07e162b1..046000653e4d8 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1266,7 +1266,7 @@ enum d_walk_ret {
......@@ -68,7 +68,7 @@ index b280e07e162b..046000653e4d 100644
{
struct dentry *this_parent;
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 2e4c0fa2074b..0b28a37f7e50 100644
index 2e4c0fa2074b0..0b28a37f7e505 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -32,7 +32,7 @@
......@@ -90,7 +90,7 @@ index 2e4c0fa2074b..0b28a37f7e50 100644
return error;
diff --git a/fs/inode.c b/fs/inode.c
index 93d9252a00ab..7700c5e4783b 100644
index 93d9252a00ab4..7700c5e4783b9 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1688,7 +1688,7 @@ EXPORT_SYMBOL(generic_update_time);
......@@ -103,7 +103,7 @@ index 93d9252a00ab..7700c5e4783b 100644
if (inode->i_op->update_time)
return inode->i_op->update_time(inode, time, flags);
diff --git a/fs/namespace.c b/fs/namespace.c
index a28e4db075ed..12e725e34c6c 100644
index a28e4db075ede..12e725e34c6ca 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -776,6 +776,12 @@ static inline int check_mnt(struct mount *mnt)
......@@ -120,7 +120,7 @@ index a28e4db075ed..12e725e34c6c 100644
* vfsmount lock must be held for write
*/
diff --git a/fs/read_write.c b/fs/read_write.c
index bbfa9b12b15e..5d684d7d2920 100644
index bbfa9b12b15eb..5d684d7d29207 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -499,6 +499,28 @@ static ssize_t __vfs_write(struct file *file, const char __user *p,
......@@ -153,7 +153,7 @@ index bbfa9b12b15e..5d684d7d2920 100644
{
mm_segment_t old_fs;
diff --git a/fs/splice.c b/fs/splice.c
index fd0a1e7e5959..15936ede85d3 100644
index 4e53efbd621db..9f230ee854e20 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -849,8 +849,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
......@@ -181,7 +181,7 @@ index fd0a1e7e5959..15936ede85d3 100644
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/fs/sync.c b/fs/sync.c
index 4d1ff010bc5a..457f4e4a5cc1 100644
index 4d1ff010bc5af..457f4e4a5cc1f 100644
--- a/fs/sync.c
+++ b/fs/sync.c
@@ -28,7 +28,7 @@
......@@ -194,7 +194,7 @@ index 4d1ff010bc5a..457f4e4a5cc1 100644
if (wait)
sync_inodes_sb(sb);
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 45cc10cdf6dd..916efd7e612b 100644
index 45cc10cdf6ddd..916efd7e612b3 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1355,6 +1355,7 @@ extern void fasync_free(struct fasync_struct *);
......@@ -243,7 +243,7 @@ index 45cc10cdf6dd..916efd7e612b 100644
extern const struct file_operations def_blk_fops;
extern const struct file_operations def_chr_fops;
diff --git a/include/linux/lockdep.h b/include/linux/lockdep.h
index 206774ac6946..e5eda5226fbc 100644
index 206774ac69460..e5eda5226fbc7 100644
--- a/include/linux/lockdep.h
+++ b/include/linux/lockdep.h
@@ -376,6 +376,8 @@ static inline int lockdep_match_key(struct lockdep_map *lock,
......@@ -264,7 +264,7 @@ index 206774ac6946..e5eda5226fbc 100644
#define lockdep_assert_held(l) do { (void)(l); } while (0)
diff --git a/include/linux/mnt_namespace.h b/include/linux/mnt_namespace.h
index 35942084cd40..24f5fd1a789d 100644
index 35942084cd40d..24f5fd1a789de 100644
--- a/include/linux/mnt_namespace.h
+++ b/include/linux/mnt_namespace.h
@@ -6,11 +6,14 @@
......@@ -283,7 +283,7 @@ index 35942084cd40..24f5fd1a789d 100644
extern const struct file_operations proc_mountinfo_operations;
extern const struct file_operations proc_mountstats_operations;
diff --git a/include/linux/splice.h b/include/linux/splice.h
index ebbbfea48aa0..d68d57425028 100644
index ebbbfea48aa0b..d68d574250283 100644
--- a/include/linux/splice.h
+++ b/include/linux/splice.h
@@ -90,4 +90,10 @@ extern void splice_shrink_spd(struct splice_pipe_desc *);
......@@ -298,7 +298,7 @@ index ebbbfea48aa0..d68d57425028 100644
+ unsigned int flags);
#endif
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index ac10db66cc63..837a3358e77c 100644
index ac10db66cc63f..837a3358e77ca 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -169,7 +169,7 @@ static
......
......@@ -2,7 +2,7 @@ SPDX-License-Identifier: GPL-2.0
aufs5.x-rcN kbuild patch
diff --git a/fs/Kconfig b/fs/Kconfig
index f08fbbfafd9a..1c597cddc351 100644
index f08fbbfafd9a0..1c597cddc351c 100644
--- a/fs/Kconfig
+++ b/fs/Kconfig
@@ -267,6 +267,7 @@ source "fs/sysv/Kconfig"
......@@ -14,7 +14,7 @@ index f08fbbfafd9a..1c597cddc351 100644
endif # MISC_FILESYSTEMS
diff --git a/fs/Makefile b/fs/Makefile
index 2ce5112b02c8..d9b4a5198553 100644
index 2ce5112b02c86..d9b4a51985538 100644
--- a/fs/Makefile
+++ b/fs/Makefile
@@ -136,3 +136,4 @@ obj-$(CONFIG_EFIVAR_FS) += efivarfs/
......
......@@ -2,7 +2,7 @@ SPDX-License-Identifier: GPL-2.0
aufs5.x-rcN loopback patch
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index 0479902a0cd5..758c8ee4d4e6 100644
index 0479902a0cd50..758c8ee4d4e6b 100644
--- a/drivers/block/loop.c
+++ b/drivers/block/loop.c
@@ -638,6 +638,15 @@ static inline void loop_update_dio(struct loop_device *lo)
......@@ -140,7 +140,7 @@ index 0479902a0cd5..758c8ee4d4e6 100644
}
diff --git a/drivers/block/loop.h b/drivers/block/loop.h
index af75a5ee4094..1d847cb194ff 100644
index af75a5ee40944..1d847cb194ff6 100644
--- a/drivers/block/loop.h
+++ b/drivers/block/loop.h
@@ -46,7 +46,7 @@ struct loop_device {
......@@ -153,7 +153,7 @@ index af75a5ee4094..1d847cb194ff 100644
void *key_data;
diff --git a/fs/aufs/f_op.c b/fs/aufs/f_op.c
index 6fb4a4ed8cc7..ba9a959f2db2 100644
index 6fb4a4ed8cc7f..ba9a959f2db27 100644
--- a/fs/aufs/f_op.c
+++ b/fs/aufs/f_op.c
@@ -359,7 +359,7 @@ static ssize_t aufs_read_iter(struct kiocb *kio, struct iov_iter *iov_iter)
......@@ -166,7 +166,7 @@ index 6fb4a4ed8cc7..ba9a959f2db2 100644
if (file->f_mapping != h_file->f_mapping) {
file->f_mapping = h_file->f_mapping;
diff --git a/fs/aufs/loop.c b/fs/aufs/loop.c
index a8b63acc6204..9d97c3af5686 100644
index a8b63acc62045..9d97c3af5686a 100644
--- a/fs/aufs/loop.c
+++ b/fs/aufs/loop.c
@@ -133,3 +133,19 @@ void au_loopback_fin(void)
......@@ -190,7 +190,7 @@ index a8b63acc6204..9d97c3af5686 100644
+ return f;
+}
diff --git a/fs/aufs/loop.h b/fs/aufs/loop.h
index 94f4f80ae33b..ca1194354aff 100644
index 94f4f80ae33bf..ca1194354aff4 100644
--- a/fs/aufs/loop.h
+++ b/fs/aufs/loop.h
@@ -26,6 +26,8 @@ void au_warn_loopback(struct super_block *h_sb);
......@@ -212,7 +212,7 @@ index 94f4f80ae33b..ca1194354aff 100644
#endif /* __KERNEL__ */
diff --git a/fs/aufs/super.c b/fs/aufs/super.c
index 589dd0122020..801e0a7faec5 100644
index 589dd01220201..801e0a7faec59 100644
--- a/fs/aufs/super.c
+++ b/fs/aufs/super.c
@@ -844,7 +844,10 @@ static const struct super_operations aufs_sop = {
......@@ -228,7 +228,7 @@ index 589dd0122020..801e0a7faec5 100644
/* ---------------------------------------------------------------------- */
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 916efd7e612b..68f536f42b2a 100644
index 916efd7e612b3..68f536f42b2a0 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1985,6 +1985,10 @@ struct super_operations {
......
......@@ -2,7 +2,7 @@ SPDX-License-Identifier: GPL-2.0
aufs5.x-rcN mmap patch
diff --git a/fs/proc/base.c b/fs/proc/base.c
index eb2255e95f62..92f6062423c0 100644
index eb2255e95f62b..92f6062423c0c 100644
--- a/fs/proc/base.c
+++ b/fs/proc/base.c
@@ -2162,7 +2162,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
......@@ -15,7 +15,7 @@ index eb2255e95f62..92f6062423c0 100644
rc = 0;
}
diff --git a/fs/proc/nommu.c b/fs/proc/nommu.c
index 14c2badb8fd9..65afe5287e43 100644
index 14c2badb8fd93..65afe5287e43e 100644
--- a/fs/proc/nommu.c
+++ b/fs/proc/nommu.c
@@ -41,7 +41,10 @@ static int nommu_region_show(struct seq_file *m, struct vm_region *region)
......@@ -31,7 +31,7 @@ index 14c2badb8fd9..65afe5287e43 100644
ino = inode->i_ino;
}
diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
index 8d382d4ec067..93a768f754c9 100644
index 8d382d4ec0672..93a768f754c91 100644
--- a/fs/proc/task_mmu.c
+++ b/fs/proc/task_mmu.c
@@ -280,7 +280,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma)
......@@ -56,7 +56,7 @@ index 8d382d4ec067..93a768f754c9 100644
struct mempolicy *pol;
char buffer[64];
diff --git a/fs/proc/task_nommu.c b/fs/proc/task_nommu.c
index 7907e6419e57..d17209cf52bc 100644
index 7907e6419e572..d17209cf52bc3 100644
--- a/fs/proc/task_nommu.c
+++ b/fs/proc/task_nommu.c
@@ -155,7 +155,10 @@ static int nommu_vma_show(struct seq_file *m, struct vm_area_struct *vma)
......@@ -72,10 +72,10 @@ index 7907e6419e57..d17209cf52bc 100644
ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index 5a323422d783..b62bf044d668 100644
index f3fe7371855ce..a5b9751a5b331 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1677,6 +1677,28 @@ static inline void unmap_shared_mapping_range(struct address_space *mapping,
@@ -1688,6 +1688,28 @@ static inline void unmap_shared_mapping_range(struct address_space *mapping,
unmap_mapping_range(mapping, holebegin, holelen, 0);
}
......@@ -105,7 +105,7 @@ index 5a323422d783..b62bf044d668 100644
void *buf, int len, unsigned int gup_flags);
extern int access_remote_vm(struct mm_struct *mm, unsigned long addr,
diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h
index 4aba6c0c2ba8..974802987f69 100644
index 4aba6c0c2ba80..974802987f69d 100644
--- a/include/linux/mm_types.h
+++ b/include/linux/mm_types.h
@@ -272,6 +272,7 @@ struct vm_region {
......@@ -125,7 +125,7 @@ index 4aba6c0c2ba8..974802987f69 100644
#ifdef CONFIG_SWAP
diff --git a/kernel/fork.c b/kernel/fork.c
index 8c700f881d92..f76083fea4dc 100644
index 48ed22774efaa..d7439388c1c52 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -568,7 +568,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
......@@ -138,7 +138,7 @@ index 8c700f881d92..f76083fea4dc 100644
atomic_dec(&inode->i_writecount);
i_mmap_lock_write(mapping);
diff --git a/mm/Makefile b/mm/Makefile
index fccd3756b25f..51485ceec650 100644
index fccd3756b25f0..51485ceec650a 100644
--- a/mm/Makefile
+++ b/mm/Makefile
@@ -44,7 +44,7 @@ obj-y := filemap.o mempool.o oom_kill.o fadvise.o \
......@@ -151,7 +151,7 @@ index fccd3756b25f..51485ceec650 100644
# Give 'page_alloc' its own module-parameter namespace
page-alloc-y := page_alloc.o
diff --git a/mm/filemap.c b/mm/filemap.c
index 23a051a7ef0f..e2fe9132feb2 100644
index 23a051a7ef0fb..e2fe9132feb21 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -2660,7 +2660,7 @@ vm_fault_t filemap_page_mkwrite(struct vm_fault *vmf)
......@@ -164,7 +164,7 @@ index 23a051a7ef0f..e2fe9132feb2 100644
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/mmap.c b/mm/mmap.c
index f609e9ec4a25..d554b349c653 100644
index f609e9ec4a253..d554b349c653c 100644
--- a/mm/mmap.c
+++ b/mm/mmap.c
@@ -179,7 +179,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma)
......@@ -261,7 +261,7 @@ index f609e9ec4a25..d554b349c653 100644
new_vma->vm_ops->open(new_vma);
vma_link(mm, new_vma, prev, rb_link, rb_parent);
diff --git a/mm/nommu.c b/mm/nommu.c
index 318df4e236c9..7f051e86ea1d 100644
index 318df4e236c99..7f051e86ea1dd 100644
--- a/mm/nommu.c
+++ b/mm/nommu.c
@@ -567,7 +567,7 @@ static void __put_nommu_region(struct vm_region *region)
......@@ -306,7 +306,7 @@ index 318df4e236c9..7f051e86ea1d 100644
diff --git a/mm/prfile.c b/mm/prfile.c
new file mode 100644
index 000000000000..00d51187c325
index 0000000000000..00d51187c3250
--- /dev/null
+++ b/mm/prfile.c
@@ -0,0 +1,86 @@
......
......@@ -2,7 +2,7 @@ SPDX-License-Identifier: GPL-2.0
aufs5.x-rcN standalone patch
diff --git a/fs/dcache.c b/fs/dcache.c
index 046000653e4d..15aa871d1b45 100644
index 046000653e4d8..15aa871d1b450 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1371,6 +1371,7 @@ void d_walk(struct dentry *parent, void *data,
......@@ -22,7 +22,7 @@ index 046000653e4d..15aa871d1b45 100644
/**
* d_ancestor - search for an ancestor
diff --git a/fs/exec.c b/fs/exec.c
index 06b4c550af5d..afb0213b0c2c 100644
index 2c465119affcc..239bcb8906e78 100644
--- a/fs/exec.c
+++ b/fs/exec.c
@@ -109,6 +109,7 @@ bool path_noexec(const struct path *path)
......@@ -34,7 +34,7 @@ index 06b4c550af5d..afb0213b0c2c 100644
#ifdef CONFIG_USELIB
/*
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 0b28a37f7e50..f2c90a416b75 100644
index 0b28a37f7e505..f2c90a416b751 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -85,6 +85,7 @@ int setfl(int fd, struct file *filp, unsigned long arg)
......@@ -46,7 +46,7 @@ index 0b28a37f7e50..f2c90a416b75 100644
static void f_modown(struct file *filp, struct pid *pid, enum pid_type type,
int force)
diff --git a/fs/file_table.c b/fs/file_table.c
index 30d55c9a1744..34b9bbf4c556 100644
index 30d55c9a1744a..34b9bbf4c5566 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
@@ -162,6 +162,7 @@ struct file *alloc_empty_file(int flags, const struct cred *cred)
......@@ -66,7 +66,7 @@ index 30d55c9a1744..34b9bbf4c556 100644
void __init files_init(void)
{
diff --git a/fs/inode.c b/fs/inode.c
index 7700c5e4783b..6284b41fcf3f 100644
index 7700c5e4783b9..6284b41fcf3f0 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1694,6 +1694,7 @@ int update_time(struct inode *inode, struct timespec64 *time, int flags)
......@@ -78,7 +78,7 @@ index 7700c5e4783b..6284b41fcf3f 100644
/**
* touch_atime - update the access time
diff --git a/fs/namespace.c b/fs/namespace.c
index 12e725e34c6c..fa17b9d5926b 100644
index 12e725e34c6ca..fa17b9d5926ba 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -431,6 +431,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
......@@ -106,7 +106,7 @@ index 12e725e34c6c..fa17b9d5926b 100644
static void lock_mnt_tree(struct mount *mnt)
{
diff --git a/fs/notify/group.c b/fs/notify/group.c
index 133f723aca07..0b9f7f6d8390 100644
index 133f723aca070..0b9f7f6d8390f 100644
--- a/fs/notify/group.c
+++ b/fs/notify/group.c
@@ -99,6 +99,7 @@ void fsnotify_get_group(struct fsnotify_group *group)
......@@ -118,7 +118,7 @@ index 133f723aca07..0b9f7f6d8390 100644
/*
* Drop a reference to a group. Free it if it's through.
diff --git a/fs/open.c b/fs/open.c
index 719b320ede52..f88ce55c1c99 100644
index 719b320ede52b..f88ce55c1c998 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -65,6 +65,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
......@@ -130,7 +130,7 @@ index 719b320ede52..f88ce55c1c99 100644
long vfs_truncate(const struct path *path, loff_t length)
{
diff --git a/fs/read_write.c b/fs/read_write.c
index 5d684d7d2920..6f61c0b6aa66 100644
index 5d684d7d29207..6f61c0b6aa664 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -469,6 +469,7 @@ ssize_t vfs_read(struct file *file, char __user *buf, size_t count, loff_t *pos)
......@@ -166,7 +166,7 @@ index 5d684d7d2920..6f61c0b6aa66 100644
/* file_ppos returns &file->f_pos or NULL if file is stream */
static inline loff_t *file_ppos(struct file *file)
diff --git a/fs/splice.c b/fs/splice.c
index 15936ede85d3..ad4b04977557 100644
index 9f230ee854e20..a6bd05004433c 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -862,6 +862,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
......@@ -186,7 +186,7 @@ index 15936ede85d3..ad4b04977557 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/fs/sync.c b/fs/sync.c
index 457f4e4a5cc1..67c66358f3fe 100644
index 457f4e4a5cc1f..67c66358f3fe4 100644
--- a/fs/sync.c
+++ b/fs/sync.c
@@ -39,6 +39,7 @@ int __sync_filesystem(struct super_block *sb, int wait)
......@@ -198,7 +198,7 @@ index 457f4e4a5cc1..67c66358f3fe 100644
/*
* Write out and wait upon all dirty data associated with this
diff --git a/fs/xattr.c b/fs/xattr.c
index e13265e65871..204b47bb0542 100644
index 91608d9bfc6aa..02d19ab3ba540 100644
--- a/fs/xattr.c
+++ b/fs/xattr.c
@@ -296,6 +296,7 @@ vfs_getxattr_alloc(struct dentry *dentry, const char *name, char **xattr_value,
......@@ -210,7 +210,7 @@ index e13265e65871..204b47bb0542 100644
ssize_t
__vfs_getxattr(struct dentry *dentry, struct inode *inode, const char *name,
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index 837a3358e77c..715ba9c1b91a 100644
index 837a3358e77ca..715ba9c1b91ae 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -190,6 +190,7 @@ inline struct lock_class *lockdep_hlock_class(struct held_lock *hlock)
......@@ -222,7 +222,7 @@ index 837a3358e77c..715ba9c1b91a 100644
#ifdef CONFIG_LOCK_STAT
diff --git a/kernel/task_work.c b/kernel/task_work.c
index 825f28259a19..b77593b29c1a 100644
index 825f28259a19a..b77593b29c1a5 100644
--- a/kernel/task_work.c
+++ b/kernel/task_work.c
@@ -126,3 +126,4 @@ void task_work_run(void)
......@@ -231,7 +231,7 @@ index 825f28259a19..b77593b29c1a 100644
}
+EXPORT_SYMBOL_GPL(task_work_run);
diff --git a/security/security.c b/security/security.c
index 7fed24b9d57e..b20a759ba8de 100644
index 51de970fbb1ed..b21f1ffd90051 100644
--- a/security/security.c
+++ b/security/security.c
@@ -1087,6 +1087,7 @@ int security_path_rmdir(const struct path *dir, struct dentry *dentry)
......
This diff is collapsed.
......@@ -2,7 +2,7 @@ SPDX-License-Identifier: GPL-2.0
aufs5.x-rcN lockdep patch
diff --git a/include/linux/lockdep.h b/include/linux/lockdep.h
index e5eda5226fbc..761f87256a9f 100644
index e5eda5226fbc7..761f87256a9f1 100644
--- a/include/linux/lockdep.h
+++ b/include/linux/lockdep.h
@@ -17,7 +17,7 @@ struct lockdep_map;
......@@ -15,11 +15,11 @@ index e5eda5226fbc..761f87256a9f 100644
#include <linux/types.h>
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index 715ba9c1b91a..9caea35fb957 100644
index 715ba9c1b91ae..9caea35fb9579 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
diff --git a/kernel/locking/lockdep_internals.h b/kernel/locking/lockdep_internals.h
index baca699b94e9..11ebf13738f4 100644
index baca699b94e91..11ebf13738f40 100644
--- a/kernel/locking/lockdep_internals.h
+++ b/kernel/locking/lockdep_internals.h
@@ -94,15 +94,15 @@ static const unsigned long LOCKF_USED_IN_IRQ_READ =
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment